Password Protect WordPress Lite Version

Password protect WordPress pages and posts by user roles or with multiple passwords; protect your entire website with a single password. Our lite version offers the following functionalities:

Protect WordPress pages & posts with Multiple Passwords

The plugin extends the default password protected WordPress feature by allowing you to set multiple passwords per Page and Post.

All your passwords, including the default password which is created by WordPress feature, will be displayed and managed under our plugin’s section on Edit Page.

Password protect WordPress pages & posts by Users Roles

You can also password protect your WordPress Pages & Posts by user roles. In other words, you can set different passwords for different user roles, i.e. one for subscribers, one for editors role.

As you see, there are two types of passwords in free version:

    • “Global” password: can be used by everyone.

It means anyone who visits a page protected by “global” password will see the password field and access the content once entering the right password.

    • “Role” password: can be used by a specific user role.

For example, if you set a password for “editor”, only those who access the protected page with Editor accounts will be able to enter the password. Otherwise, the password field will be hidden.

Currently, this plugin doesn’t allow you to manage all passwords of your pages or posts under configuration popup. It also restricts the number of password per user role. Please check out our premium version which offers unlimited password and many other extended features.

Password’s Cookies Expiration

Once visitors enter the right password, they won’t have to do it again until the cookies expire. Its value is 7 days by default. You can change the expiration time on our plugin’s settings page.

Password Protect the whole WordPress website

You can create one password to protect your entire website. Visitors will be required to enter password once accessing each page or post. All your website content including pages, posts and other custom post types but not media files are locked as well.

It’s important to know that our plugin doesn’t allow to create a password with spaces or duplicate passwords. It also requires WordPress 3.9 or later and PHP 5.6+.

Lasted updated on February 27, 2019